Invalid RSS Version: x.y


Released versions of RSS include:

RSS 0.93 and RSS 0.94 were never finalized.

RSS 0.90 and RSS 1.0 have a completely different XML structure, and in particular, no version attribute.


In most cases, simply changing the version attribute to 2.0 is the simplest fix.

If, however, you actually are intending to produce a valid RSS 1.0 feed, consult the specification linked above for guidance.

Not clear? Disagree?

You might be able to find help in one of these fine resources.

Copyright © 2002-4 Mark Pilgrim and Sam Ruby